Packages for crypto-development workload
in CentOS Stream 9 Environment from CentOS Stream 9 for x86_64



Size History
Additional info

Why Name Epoch:Version-Release Arch Size Summary
(dependency) acl 2.3.1-3.el9 x86_64 209.1 kB Access control list utilities
(dependency) alternatives 1.20-2.el9 x86_64 62.4 kB A tool to maintain symbolic links determining default commands
(dependency) audit-libs 3.0.5-2.el9 x86_64 300.2 kB Dynamic library for libaudit
(dependency) basesystem 11-13.el9 noarch 0.0 B The skeleton package which defines a simple Red Hat Enterprise Linux 9 system
(dependency) bash 5.1.8-3.el9 x86_64 7.4 MB The GNU Bourne Again shell
(dependency) bzip2-libs 1.0.8-8.el9 x86_64 76.9 kB Libraries for applications using bzip2
(dependency) ca-certificates 2020.2.50-93.el9 noarch 917.6 kB The Mozilla CA root certificate bundle
(env) centos-gpg-keys 9.0-3.el9 noarch 1.6 kB CentOS RPM keys
(env) centos-stream-release 9.0-3.el9 noarch 27.7 kB CentOS Stream release files
(env) centos-stream-repos 9.0-3.el9 noarch 6.0 kB CentOS Stream package repositories
(dependency) cmake-filesystem 3.20.2-7.el9 x86_64 0.0 B Directories used by CMake modules
(dependency) coreutils 8.32-31.el9 x86_64 5.8 MB A set of basic GNU tools commonly used in shell scripts
(dependency) coreutils-common 8.32-31.el9 x86_64 10.4 MB coreutils common optional components
(dependency) cracklib 2.9.6-27.el9 x86_64 245.9 kB A password-checking library
(dependency) cracklib-dicts 2.9.6-27.el9 x86_64 9.4 MB The standard CrackLib dictionaries
(dependency) crypto-policies 20210707-2.git29f6c0b.el9 noarch 82.4 kB System-wide crypto policies
(dependency) crypto-policies-scripts 20210707-2.git29f6c0b.el9 noarch 214.7 kB Tool to switch between crypto policies
(dependency) cryptsetup-libs 2.4.1-1.el9 x86_64 1.8 MB Cryptsetup shared library
(dependency) cyrus-sasl 2.1.27-17.el9 x86_64 145.2 kB The Cyrus SASL library
(required) cyrus-sasl-devel 2.1.27-17.el9 x86_64 207.5 kB Files needed for developing applications with Cyrus SASL
(dependency) cyrus-sasl-lib 2.1.27-17.el9 x86_64 2.3 MB Shared libraries needed by applications which use Cyrus SASL
(dependency) dbus 1:1.12.20-5.el9 x86_64 0.0 B D-BUS message bus
(dependency) dbus-broker 28-5.el9 x86_64 387.1 kB Linux D-Bus Message Broker
(dependency) dbus-common 1:1.12.20-5.el9 noarch 11.2 kB D-BUS message bus configuration
(dependency) device-mapper 9:1.02.181-1.el9 x86_64 353.0 kB Device mapper utility
(dependency) device-mapper-libs 9:1.02.181-1.el9 x86_64 416.1 kB Device-mapper shared library
(dependency) elfutils-default-yama-scope 0.185-5.el9 noarch 1.8 kB Default yama attach scope sysctl setting
(dependency) elfutils-libelf 0.185-5.el9 x86_64 969.0 kB Library to read and write ELF files
(dependency) elfutils-libs 0.185-5.el9 x86_64 692.6 kB Libraries to handle compiled objects
(dependency) expat 2.2.10-4.el9 x86_64 264.4 kB An XML parser library
(dependency) filesystem 3.16-2.el9 x86_64 106.0 B The basic directory layout for a Linux system
(dependency) gawk 5.1.0-5.el9 x86_64 1.6 MB The GNU version of the AWK text processing utility
(dependency) gdbm-libs 1:1.19-4.el9 x86_64 113.6 kB Libraries files for gdbm
(dependency) glibc 2.34-7.el9 x86_64 6.0 MB The GNU libc libraries
(dependency) glibc-common 2.34-7.el9 x86_64 1.0 MB Common binaries and locale data for glibc
(dependency) glibc-minimal-langpack 2.34-7.el9 x86_64 0.0 B Minimal language packs for glibc.
(dependency) gmp 1:6.2.0-10.el9 x86_64 798.9 kB A GNU arbitrary precision library
(dependency) gmp-c++ 1:6.2.0-10.el9 x86_64 31.9 kB C++ bindings for the GNU MP arbitrary precision library
(dependency) gmp-devel 1:6.2.0-10.el9 x86_64 350.6 kB Development tools for the GNU MP arbitrary precision library
(dependency) gnutls 3.7.2-7.el9 x86_64 2.7 MB A TLS protocol implementation
(dependency) gnutls-c++ 3.7.2-7.el9 x86_64 73.0 kB The C++ interface to GnuTLS
(dependency) gnutls-dane 3.7.2-7.el9 x86_64 27.9 kB A DANE protocol implementation for GnuTLS
(required) gnutls-devel 3.7.2-7.el9 x86_64 4.9 MB Development files for the gnutls package
(dependency) grep 3.6-5.el9 x86_64 837.7 kB Pattern matching utilities
(dependency) gzip 1.10-8.el9 x86_64 349.0 kB The GNU data compression program
(dependency) json-c 0.14-11.el9 x86_64 77.4 kB JSON implementation in C
(dependency) keyutils-libs 1.6.1-4.el9 x86_64 54.6 kB Key utilities library
(dependency) kmod-libs 28-5.el9 x86_64 131.3 kB Libraries to handle kernel module loading and unloading
(dependency) krb5-libs 1.19.1-11.el9.1 x86_64 2.1 MB The non-admin shared libraries used by Kerberos 5
(dependency) libacl 2.3.1-3.el9 x86_64 40.2 kB Dynamic library for access control list support
(dependency) libattr 2.5.1-3.el9 x86_64 28.7 kB Dynamic library for extended attribute support
(dependency) libblkid 2.37.2-1.el9 x86_64 221.4 kB Block device ID library
(dependency) libcap 2.48-7.el9 x86_64 177.5 kB Library for getting and setting POSIX.1e capabilities
(dependency) libcap-ng 0.8.2-6.el9 x86_64 73.4 kB Alternate posix capabilities library
(dependency) libcom_err 1.46.2-2.el9 x86_64 67.4 kB Common error description library
(dependency) libdb 5.3.28-51.el9 x86_64 1.8 MB The Berkeley DB database library for C
(dependency) libeconf 0.4.1-2.el9 x86_64 45.3 kB Enhanced config file parser library
(dependency) libevent 2.1.12-6.el9 x86_64 910.4 kB Abstract asynchronous event notification library
(dependency) libfdisk 2.37.2-1.el9 x86_64 360.3 kB Partitioning library for fdisk-like programs.
(dependency) libffi 3.4.2-7.el9 x86_64 64.8 kB A portable foreign function interface library
(dependency) libgcc 11.2.1-2.2.el9 x86_64 194.1 kB GCC version 11 shared support library
(dependency) libgcrypt 1.9.3-5.el9 x86_64 1.3 MB A general-purpose cryptography library
(required) libgcrypt-devel 1.9.3-5.el9 x86_64 246.1 kB Development files for the libgcrypt package
(dependency) libgpg-error 1.42-4.el9 x86_64 817.4 kB Library for error values used by GnuPG components
(dependency) libgpg-error-devel 1.42-4.el9 x86_64 227.6 kB Development files for the libgpg-error package
(dependency) libidn2 2.3.0-7.el9 x86_64 247.5 kB Library to support IDNA2008 internationalized domain names
(dependency) libidn2-devel 2.3.0-7.el9 x86_64 210.9 kB Development files for libidn2
(dependency) libmount 2.37.2-1.el9 x86_64 303.9 kB Device mounting library
(dependency) libnghttp2 1.43.0-5.el9 x86_64 166.9 kB A library implementing the HTTP/2 protocol
(dependency) libpkgconf 1.7.3-9.el9 x86_64 74.3 kB Backend library for pkgconf
(dependency) libpwquality 1.4.4-8.el9 x86_64 406.6 kB A library for password generation and password quality checking
(required) libpwquality-devel 1.4.4-8.el9 x86_64 10.4 kB Support for development of applications using the libpwquality library
(dependency) libseccomp 2.5.0-6.el9 x86_64 173.9 kB Enhanced seccomp library
(dependency) libselinux 3.3-0.rc2.1.el9 x86_64 165.5 kB SELinux library and simple utilities
(dependency) libsemanage 3.3-0.rc2.1.el9 x86_64 296.8 kB SELinux binary policy manipulation library
(dependency) libsepol 3.3-0.rc2.1.el9 x86_64 738.3 kB SELinux binary policy manipulation library
(dependency) libsigsegv 2.13-4.el9 x86_64 49.2 kB Library for handling page faults in user mode
(dependency) libsmartcols 2.37.2-1.el9 x86_64 132.3 kB Formatting library for ls-like programs.
(dependency) libssh 0.9.6-1.el9 x86_64 501.3 kB A library implementing the SSH protocol
(dependency) libssh-config 0.9.6-1.el9 noarch 277.0 B Configuration files for libssh
(required) libssh-devel 0.9.6-1.el9 x86_64 150.0 kB Development files for libssh
(dependency) libstdc++ 11.2.1-2.2.el9 x86_64 2.4 MB GNU Standard C++ Library
(dependency) libtasn1 4.16.0-7.el9 x86_64 179.7 kB The ASN.1 library used in GNUTLS
(dependency) libtasn1-devel 4.16.0-7.el9 x86_64 330.2 kB Files for development of applications which will use libtasn1
(dependency) libtasn1-tools 4.16.0-7.el9 x86_64 49.3 kB Some ASN.1 tools
(dependency) libunistring 0.9.10-15.el9 x86_64 1.6 MB GNU Unicode string library
(dependency) libutempter 1.2.1-6.el9 x86_64 58.0 kB A privileged helper for utmp/wtmp updates
(dependency) libuuid 2.37.2-1.el9 x86_64 33.7 kB Universally unique ID library
(dependency) libverto 0.3.2-3.el9 x86_64 29.7 kB Main loop abstraction library
(dependency) libxcrypt 4.4.18-3.el9 x86_64 264.3 kB Extended crypt library for descrypt, md5crypt, bcrypt, and others
(dependency) libzstd 1.5.0-2.el9 x86_64 1000.2 kB Zstd shared library
(dependency) lz4-libs 1.9.3-5.el9 x86_64 142.1 kB Libaries for lz4
(dependency) mpfr 4.1.0-7.el9 x86_64 783.7 kB C library for multiple-precision floating-point computations
(dependency) ncurses-base 6.2-8.20210508.el9 noarch 300.1 kB Descriptions of common terminals
(dependency) ncurses-libs 6.2-8.20210508.el9 x86_64 974.0 kB Ncurses libraries
(dependency) nettle 3.7.3-2.el9 x86_64 718.2 kB A low-level cryptographic library
(dependency) nettle-devel 3.7.3-2.el9 x86_64 1.4 MB Development headers for a low-level cryptographic library
(dependency) nspr 4.32.0-4.el9 x86_64 322.0 kB Netscape Portable Runtime
(dependency) nspr-devel 4.32.0-4.el9 x86_64 448.7 kB Development libraries for the Netscape Portable Runtime
(dependency) nss 3.71.0-2.el9 x86_64 2.0 MB Network Security Services
(required) nss-devel 3.71.0-2.el9 x86_64 1.3 MB Development libraries for Network Security Services
(dependency) nss-softokn 3.71.0-2.el9 x86_64 1.7 MB Network Security Services Softoken Module
(dependency) nss-softokn-devel 3.71.0-2.el9 x86_64 10.7 kB Development libraries for Network Security Services
(dependency) nss-softokn-freebl 3.71.0-2.el9 x86_64 748.1 kB Freebl library for the Network Security Services
(dependency) nss-softokn-freebl-devel 3.71.0-2.el9 x86_64 610.8 kB Header and Library files for doing development with the Freebl library for NSS
(dependency) nss-sysinit 3.71.0-2.el9 x86_64 18.5 kB System NSS Initialization
(dependency) nss-util 3.71.0-2.el9 x86_64 225.1 kB Network Security Services Utilities Library
(dependency) nss-util-devel 3.71.0-2.el9 x86_64 305.8 kB Development libraries for Network Security Services Utilities
(dependency) openldap 2.4.59-3.el9 x86_64 694.0 kB LDAP support libraries
(dependency) openssl 1:3.0.0-3.el9 x86_64 1.8 MB Utilities from the general purpose cryptography library with TLS implementation
(required) openssl-devel 1:3.0.0-3.el9 x86_64 4.6 MB Files for development of applications which will use OpenSSL
(dependency) openssl-libs 1:3.0.0-3.el9 x86_64 6.6 MB A general purpose cryptography library with TLS implementation
(dependency) p11-kit 0.24.0-4.el9 x86_64 1.6 MB Library for loading and sharing PKCS#11 modules
(dependency) p11-kit-devel 0.24.0-4.el9 x86_64 518.2 kB Development files for p11-kit
(dependency) p11-kit-trust 0.24.0-4.el9 x86_64 440.7 kB System trust module from p11-kit
(dependency) pam 1.5.1-8.el9 x86_64 1.8 MB An extensible library which provides authentication for applications
(dependency) pcre 8.44-3.el9.3 x86_64 526.6 kB Perl-compatible regular expression library
(dependency) pcre2 10.37-3.el9.1 x86_64 618.5 kB Perl-compatible regular expression library
(dependency) pcre2-syntax 10.37-3.el9.1 noarch 217.6 kB Documentation for PCRE2 regular expressions
(dependency) pkgconf 1.7.3-9.el9 x86_64 76.7 kB Package compiler and linker metadata toolkit
(dependency) pkgconf-m4 1.7.3-9.el9 noarch 13.9 kB m4 macros for pkgconf
(dependency) pkgconf-pkg-config 1.7.3-9.el9 x86_64 1.2 kB pkgconf shim to provide /usr/bin/pkg-config
(dependency) protobuf-c 1.3.3-9.el9 x86_64 62.3 kB C bindings for Google's Protocol Buffers
(dependency) python-pip-wheel 21.2.3-2.el9 noarch 1.3 MB The pip wheel
(dependency) python-setuptools-wheel 53.0.0-6.el9 noarch 549.0 kB The setuptools wheel
(dependency) python3 3.9.7-1.el9 x86_64 32.4 kB Python 3.9 interpreter
(dependency) python3-libs 3.9.7-1.el9 x86_64 30.9 MB Python runtime libraries
(dependency) readline 8.1-4.el9 x86_64 481.3 kB A library for editing typed command lines
(dependency) sed 4.8-9.el9 x86_64 794.5 kB A GNU stream text editor
(dependency) setup 2.13.7-6.el9 noarch 709.5 kB A set of system configuration and setup files
(dependency) shadow-utils 2:4.9-2.el9 x86_64 3.7 MB Utilities for managing accounts and shadow password files
(dependency) sqlite-libs 3.34.1-5.el9 x86_64 1.3 MB Shared library for the sqlite3 embeddable SQL database engine.
(dependency) systemd 249-8.el9 x86_64 12.0 MB System and Service Manager
(dependency) systemd-libs 249-8.el9 x86_64 1.7 MB systemd libraries
(dependency) systemd-pam 249-8.el9 x86_64 503.0 kB systemd PAM module
(dependency) systemd-rpm-macros 249-8.el9 noarch 8.6 kB Macros that define paths and scriptlets related to systemd
(dependency) tzdata 2021c-1.el9 noarch 1.7 MB Timezone data
(dependency) unbound-libs 1.13.1-9.el9 x86_64 1.4 MB Libraries used by the unbound server and client applications
(dependency) util-linux 2.37.2-1.el9 x86_64 10.7 MB A collection of basic system utilities
(dependency) util-linux-core 2.37.2-1.el9 x86_64 1.2 MB The most essential utilities from the util-linux suite.
(dependency) xz-libs 5.2.5-7.el9 x86_64 177.3 kB Libraries for decoding LZMA compression
(dependency) zlib 1.2.11-31.el9 x86_64 198.8 kB Compression and decompression library
Page refreshed at 24 October 2021 21:16 UTC.