Node.js runtime workload
in ELN Environment from Fedora ELN (backed by rawhide) for ppc64le



Size History
Additional info
Configuration
sst_cs_apps-nodejs.yaml

Why Name Epoch:Version-Release Arch Size Summary
(dependency) alternatives 1.21-2.eln125 ppc64le 218.5 kB A tool to maintain symbolic links determining default commands
(dependency) audit-libs 3.0.9-3.eln125 ppc64le 547.8 kB Dynamic library for libaudit
(dependency) basesystem 11-15.eln125 noarch 0.0 B The skeleton package which defines a simple Fedora system
(dependency) bash 5.2.15-2.eln125 ppc64le 8.6 MB The GNU Bourne Again shell
(dependency) brotli 1.0.9-11.eln125 ppc64le 902.1 kB Lossless compression algorithm
(dependency) brotli-devel 1.0.9-11.eln125 ppc64le 55.5 kB Lossless compression algorithm (development files)
(dependency) bzip2-libs 1.0.8-13.eln125 ppc64le 201.0 kB Libraries for applications using bzip2
(dependency) ca-certificates 2023.2.60-2.eln125 noarch 2.3 MB The Mozilla CA root certificate bundle
(dependency) coreutils 9.1-11.fc38 ppc64le 22.2 MB A set of basic GNU tools commonly used in shell scripts
(dependency) coreutils-common 9.1-11.fc38 ppc64le 10.8 MB coreutils common optional components
(dependency) crypto-policies 20221215-1.git9a18988.eln124 noarch 82.7 kB System-wide crypto policies
(dependency) curl 7.87.0-4.eln125 ppc64le 882.6 kB A utility for getting files from remote servers (FTP, HTTP, and others)
(dependency) cyrus-sasl-lib 2.1.28-9.eln125 ppc64le 3.5 MB Shared libraries needed by applications which use Cyrus SASL
(dependency) dwz 0.15-2.eln125 ppc64le 451.2 kB DWARF optimization and duplicate removal tool
(dependency) efi-srpm-macros 5-7.eln125 noarch 40.1 kB Common SRPM Macros for building EFI-related packages
(dependency) elfutils-libelf 0.188-5.eln125 ppc64le 1.1 MB Library to read and write ELF files
(dependency) expat 2.5.0-2.eln125 ppc64le 591.2 kB An XML parser library
(env) fedora-gpg-keys 38-0.4.eln125 noarch 120.7 kB Fedora RPM keys
(env) fedora-release-common 38-0.18.eln125 noarch 16.9 kB Fedora release files
(env) fedora-release-eln 38-0.18.eln125 noarch 0.0 B Base package for Fedora ELN specific default configurations
(env) fedora-release-identity-eln 38-0.18.eln125 noarch 1.4 kB Package providing the identity for Fedora ELN
(env) fedora-repos 38-0.4.eln125 noarch 4.5 kB Fedora package repositories
(env) fedora-repos-eln 38-0.4.eln125 noarch 13.1 kB ELN repo definitions
(env) fedora-repos-rawhide 38-0.4.eln125 noarch 2.2 kB Rawhide repo definitions
(dependency) file 5.44-1.eln125 ppc64le 267.0 kB Utility for determining file types
(dependency) file-libs 5.44-1.eln125 ppc64le 9.8 MB Libraries for applications using libmagic
(dependency) filesystem 3.18-3.eln125 ppc64le 106.0 B The basic directory layout for a Linux system
(dependency) findutils 1:4.9.0-3.eln125 ppc64le 1.8 MB The GNU versions of find utilities (find and xargs)
(dependency) fonts-srpm-macros 1:2.0.5-11.eln125 noarch 55.3 kB Source-stage rpm automation for fonts packages
(dependency) gawk 5.1.1-5.eln125 ppc64le 4.3 MB The GNU version of the AWK text processing utility
(dependency) gdbm-libs 1:1.23-3.eln125 ppc64le 425.3 kB Libraries files for gdbm
(dependency) ghc-srpm-macros 1.6.1-1.eln125 noarch 369.0 B RPM macros for building Haskell source packages
(dependency) glibc 2.36.9000-24.eln125 ppc64le 11.5 MB The GNU libc libraries
(dependency) glibc-common 2.36.9000-24.eln125 ppc64le 2.6 MB Common binaries and locale data for glibc
(dependency) glibc-gconv-extra 2.36.9000-24.eln125 ppc64le 49.0 MB All iconv converter modules for glibc.
(dependency) glibc-minimal-langpack 2.36.9000-24.eln125 ppc64le 0.0 B Minimal language packs for glibc.
(dependency) gmp 1:6.2.1-4.eln125 ppc64le 849.9 kB GNU arbitrary precision library
(dependency) go-srpm-macros 3.2.0-2.eln125 noarch 59.2 kB Source-stage rpm automation for Go packages
(dependency) grep 3.8-3.eln125 ppc64le 1.1 MB Pattern matching utilities
(dependency) kernel-srpm-macros 1.0-16.eln125 noarch 1.0 kB RPM macros that list arches the full kernel is built on
(dependency) keyutils-libs 1.6.1-6.eln125 ppc64le 226.4 kB Key utilities library
(dependency) krb5-libs 1.20.1-8.eln125 ppc64le 3.4 MB The non-admin shared libraries used by Kerberos 5
(dependency) libacl 2.3.1-6.eln125 ppc64le 196.0 kB Dynamic library for access control list support
(dependency) libarchive 3.6.1-4.eln125 ppc64le 1.3 MB A library for handling streaming archive formats
(dependency) libattr 2.5.1-6.eln125 ppc64le 196.6 kB Dynamic library for extended attribute support
(dependency) libb2 0.98.1-8.eln125 ppc64le 202.4 kB C library providing BLAKE2b, BLAKE2s, BLAKE2bp, BLAKE2sp
(dependency) libbrotli 1.0.9-11.eln125 ppc64le 1.2 MB Library for brotli lossless compression algorithm
(dependency) libcap 2.48-6.eln125 ppc64le 1.4 MB Library for getting and setting POSIX.1e capabilities
(dependency) libcap-ng 0.8.3-5.eln125 ppc64le 415.7 kB Alternate posix capabilities library
(dependency) libcom_err 1.46.5-4.eln125 ppc64le 239.4 kB Common error description library
(dependency) libcurl 7.87.0-4.eln125 ppc64le 917.6 kB A library for getting files from web servers
(dependency) libevent 2.1.12-8.eln125 ppc64le 1.6 MB Abstract asynchronous event notification library
(dependency) libffi 3.4.4-2.eln125 ppc64le 217.6 kB A portable foreign function interface library
(dependency) libgcc 13.0.1-0.2.eln125 ppc64le 349.3 kB GCC version 13 shared support library
(dependency) libgomp 13.0.1-0.2.eln125 ppc64le 672.3 kB GCC OpenMP v4.5 shared support library
(dependency) libidn2 2.3.4-2.eln125 ppc64le 451.1 kB Library to support IDNA2008 internationalized domain names
(dependency) libnghttp2 1.51.0-2.eln125 ppc64le 262.4 kB A library implementing the HTTP/2 protocol
(dependency) libnsl2 2.0.0-5.eln125 ppc64le 222.1 kB Public client interface library for NIS(YP) and NIS+
(dependency) libpkgconf 1.8.0-5.eln125 ppc64le 198.1 kB Backend library for pkgconf
(dependency) libpsl 0.21.2-2.eln125 ppc64le 196.6 kB C library for the Publix Suffix List
(dependency) libselinux 3.5-0.rc2.1.eln125.1 ppc64le 329.4 kB SELinux library and simple utilities
(dependency) libsepol 3.5-0.rc2.1.fc38.1 ppc64le 1.0 MB SELinux binary policy manipulation library
(dependency) libsigsegv 2.14-4.eln125 ppc64le 225.4 kB Library for handling page faults in user mode
(dependency) libssh 0.10.4-3.eln125 ppc64le 708.0 kB A library implementing the SSH protocol
(dependency) libssh-config 0.10.4-3.eln125 noarch 277.0 B Configuration files for libssh
(dependency) libstdc++ 13.0.1-0.2.eln125 ppc64le 3.7 MB GNU Standard C++ Library
(dependency) libtasn1 4.19.0-2.eln125 ppc64le 347.7 kB The ASN.1 library used in GNUTLS
(dependency) libtirpc 1.3.3-1.eln125 ppc64le 339.0 kB Transport Independent RPC Library
(dependency) libunistring 1.1-3.eln125 ppc64le 1.9 MB GNU Unicode string library
(dependency) libunistring1.0 1.0-1.eln125 ppc64le 1.9 MB Compatibility version of GNU Unicode string library
(dependency) libuuid 2.38.1-4.eln125 ppc64le 197.5 kB Universally unique ID library
(dependency) libuv 1:1.44.2-3.eln125 ppc64le 531.3 kB Platform layer for node.js
(dependency) libuv-devel 1:1.44.2-3.eln125 ppc64le 100.4 kB Development libraries for libuv
(dependency) libverto 0.3.2-5.eln125 ppc64le 197.5 kB Main loop abstraction library
(dependency) libxcrypt 4.4.33-7.eln125 ppc64le 398.4 kB Extended crypt library for descrypt, md5crypt, bcrypt, and others
(dependency) libxml2 2.10.3-3.eln125 ppc64le 2.6 MB Library providing XML and HTML support
(dependency) libzstd 1.5.2-4.eln125 ppc64le 924.7 kB Zstd shared library
(dependency) lua-libs 5.4.4-8.fc38 ppc64le 457.2 kB Libraries for lua
(dependency) lua-srpm-macros 1-8.eln125 noarch 1.3 kB RPM macros for building Lua source packages
(dependency) lz4-libs 1.9.4-2.eln125 ppc64le 325.5 kB Libaries for lz4
(dependency) mpdecimal 2.5.1-6.eln125 ppc64le 329.3 kB Library for general decimal arithmetic
(dependency) mpfr 4.1.1-3.eln125 ppc64le 2.1 MB C library for multiple-precision floating-point computations
(dependency) ncurses-base 6.4-3.20230114.eln125 noarch 314.0 kB Descriptions of common terminals
(dependency) ncurses-libs 6.4-3.20230114.eln125 ppc64le 2.4 MB Ncurses libraries
(dependency) nettle 3.8-3.eln125 ppc64le 1009.5 kB A low-level cryptographic library
(required) nodejs 1:18.13.0-8.eln125 ppc64le 6.8 MB JavaScript runtime
(required) nodejs-devel 1:18.13.0-8.eln125 ppc64le 753.8 kB JavaScript runtime - development headers
(dependency) nodejs-libs 1:18.13.0-8.eln125 ppc64le 62.0 MB Node.js and v8 libraries
(required) nodejs-nodemon 2.0.3-7.eln125 noarch 2.6 MB Simple monitor script for use during development of a node.js app
(dependency) nodejs-npm 1:8.19.3-1.18.13.0.8.eln125 ppc64le 6.5 MB Node.js Package Manager
(dependency) nodejs-packaging 2022.10-2.eln125 noarch 41.3 kB RPM Macros and Utilities for Node.js Packaging
(dependency) ocaml-srpm-macros 7-3.eln125 noarch 19.3 kB OCaml architecture macros
(dependency) openblas-srpm-macros 2-13.eln125 noarch 104.0 B OpenBLAS architecture macros
(dependency) openldap 2.6.3-2.eln125 ppc64le 1.1 MB LDAP support libraries
(dependency) openssl 1:3.0.7-4.fc38 ppc64le 1.8 MB Utilities from the general purpose cryptography library with TLS implementation
(dependency) openssl-devel 1:3.0.7-4.fc38 ppc64le 4.1 MB Files for development of applications which will use OpenSSL
(dependency) openssl-libs 1:3.0.7-4.fc38 ppc64le 8.3 MB A general purpose cryptography library with TLS implementation
(dependency) p11-kit 0.24.1-6.eln125 ppc64le 2.3 MB Library for loading and sharing PKCS#11 modules
(dependency) p11-kit-trust 0.24.1-6.eln125 ppc64le 656.2 kB System trust module from p11-kit
(dependency) package-notes-srpm-macros 0.5-7.eln125 noarch 1.5 kB Generate LDFLAGS to insert .note.package section
(dependency) pcre2 10.42-1.fc38.1 ppc64le 969.7 kB Perl-compatible regular expression library
(dependency) pcre2-syntax 10.42-1.fc38.1 noarch 235.1 kB Documentation for PCRE2 regular expressions
(dependency) perl-srpm-macros 1-48.eln125 noarch 861.0 B RPM macros for building Perl source package from source repository
(dependency) pkgconf 1.8.0-5.eln125 ppc64le 231.6 kB Package compiler and linker metadata toolkit
(dependency) pkgconf-m4 1.8.0-5.eln125 noarch 13.9 kB m4 macros for pkgconf
(dependency) pkgconf-pkg-config 1.8.0-5.eln125 ppc64le 990.0 B pkgconf shim to provide /usr/bin/pkg-config
(dependency) popt 1.19-2.eln125 ppc64le 273.1 kB C library for parsing command line parameters
(dependency) publicsuffix-list-dafsa 20221208-2.eln125 noarch 69.2 kB Cross-vendor public domain suffix database in DAFSA form
(dependency) pyproject-srpm-macros 1.6.0-1.eln125 noarch 1.5 kB Minimal implementation of %pyproject_buildrequires
(dependency) python-pip-wheel 22.3.1-2.eln125 noarch 1.5 MB The pip wheel
(dependency) python-setuptools-wheel 65.5.1-2.eln125 noarch 860.3 kB The setuptools wheel
(dependency) python-srpm-macros 3.11-9.eln125 noarch 50.1 kB RPM macros for building Python source packages
(dependency) python3 3.11.1-4.eln125 ppc64le 212.8 kB Python 3.11 interpreter
(dependency) python3-libs 3.11.1-4.eln125 ppc64le 55.4 MB Python runtime libraries
(dependency) qt5-srpm-macros 5.15.8-2.eln125 noarch 492.0 B RPM macros for source Qt5 packages
(dependency) readline 8.2-3.eln125 ppc64le 817.7 kB A library for editing typed command lines
(dependency) redhat-rpm-config 246-1.eln125 noarch 192.1 kB Red Hat specific rpm configuration files
(dependency) rpm 4.18.0-10.eln125 ppc64le 4.6 MB The RPM package management system
(dependency) rpm-libs 4.18.0-10.eln125 ppc64le 1.2 MB Libraries for manipulating RPM packages
(dependency) rpm-sequoia 1.2.0-2.eln125 ppc64le 4.4 MB Implementation of the RPM PGP interface using Sequoia
(dependency) rpmautospec-rpm-macros 0.3.2-1.eln125 noarch 707.0 B Rpmautospec RPM macros for local rpmbuild
(dependency) rust-srpm-macros 23-2.eln125 noarch 2.4 kB RPM macros for building Rust source packages
(dependency) sed 4.8-12.eln125 ppc64le 942.0 kB A GNU stream text editor
(dependency) setup 2.14.3-2.eln125 noarch 720.2 kB A set of system configuration and setup files
(dependency) sqlite-libs 3.40.1-2.eln125 ppc64le 1.8 MB Shared library for the sqlite3 embeddable SQL database engine.
(dependency) tzdata 2022g-2.eln125 noarch 1.6 MB Timezone data
(dependency) unzip 6.0-60.eln125 ppc64le 855.6 kB A utility for unpacking zip files
(dependency) xz-libs 5.4.1-1.eln125 ppc64le 329.3 kB Libraries for decoding LZMA compression
(dependency) zip 3.0-36.eln125 ppc64le 1.2 MB A file compression and packaging utility compatible with PKZIP
(dependency) zlib 1.2.13-3.eln125 ppc64le 363.1 kB Compression and decompression library
(dependency) zlib-devel 1.2.13-3.eln125 ppc64le 139.1 kB Header files and libraries for Zlib development
Page refreshed at 1 February 2023 04:23 UTC.